$re = '/^([A-Z0-9])(?!(\1|&)+$)(?=.{11,13}$)[A-Z0-9]*(?:[&][A-Z0-9]+)?$/m';
$str = 'allowed
111111111112
1111111&11112
125478&563254
ABC123567GHDG4
ABC1235&67GHD
ABCDEFGHIJKLR
1254789563254
125478&563254
not allowed
1111111&11111
125478556325&
&ABCDEFGHIJKL
&125478556325
ABCDEFGHIJKL&
&ABCDEFGHIJKL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);