using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_)\w+\s+(.*)";
string input = @"21 High Street _Earth Mighty Motor Mechanic
21 High Street _Earth Mighty Motor Mechanic _high street";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}