re = /(?<=_)\w+\s+(.*)/m
str = '21 High Street _Earth Mighty Motor Mechanic
21 High Street _Earth Mighty Motor Mechanic _high street'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end