const regex = /(POST|CONNECT|GET)\s(.*)\s(HTTP.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(POST|CONNECT|GET)\\s(.*)\\s(HTTP.*)', 'gm')
const str = `CONNECT google.com:443 HTTP/1.1
POST https://myim3app.indosatooredoo.com/api/v1/profile/get HTTP/1.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}