$re = '/(POST|CONNECT|GET)\s(.*)\s(HTTP.*)/m';
$str = 'CONNECT google.com:443 HTTP/1.1
POST https://myim3app.indosatooredoo.com/api/v1/profile/get HTTP/1.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);