$re = '/^(?!.*\basdf\b).*$/m';
$str = 'some content before, then asdf as a word, some after
some content before, then noasdf as a word, some after';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);