re = /^(?!.*\basdf\b).*$/m
str = 'some content before, then asdf as a word, some after
some content before, then noasdf as a word, some after'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end