import re
regex = re.compile(r"^record(?<id>\d+),[0-9\#\$\%\-\+\,]+,(?<name>\w+),[\D\,]+,(?<PostalCode>\d+),[0-9\#\$\%\-\+\,]+,(?<Status>(true|false)),End$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("record18,$65535,sisoog,do,5463213,33436,12,18,-17,+16,78,trUe,End\n"
"record15,#15,25,45,sisoog,s,is,oog,5463213,6,-7,78,33-43,True,End\n"
"record16,55,-35,sisoog,End,use,wait,546365213,#88,15,5485,False,End\n"
"record17,15,-45,351,sisoog,do,wait,smit,5463213,33-436,faLse,End\n"
"record17,15,-45,351,sisoog,do,smit,5463213,3436,End")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")