import Foundation
let pattern = ##"^record(?<id>\d+),[0-9\#\$\%\-\+\,]+,(?<name>\w+),[\D\,]+,(?<PostalCode>\d+),[0-9\#\$\%\-\+\,]+,(?<Status>(true|false)),End$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
record18,$65535,sisoog,do,5463213,33436,12,18,-17,+16,78,trUe,End
record15,#15,25,45,sisoog,s,is,oog,5463213,6,-7,78,33-43,True,End
record16,55,-35,sisoog,End,use,wait,546365213,#88,15,5485,False,End
record17,15,-45,351,sisoog,do,wait,smit,5463213,33-436,faLse,End
record17,15,-45,351,sisoog,do,smit,5463213,3436,End
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)