package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<rd_no>\w?\d+(\-\d+)?\w?\s+)(?P<rd_nm>[a-zA-z \-]+)\s+(?P<rd_tp>Terrace|Way|Walk|St|Rd|Ave|Cl|Ct|Cres|Blvd|Dr|Ln|Pl|Sq|Pde)`)
var str = `Burrah lodge, 15 Anne Jameson Pl
123 Main St
Unit 84 56 Newcombe Terrace`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}