const regex = new RegExp('(?P<rd_no>\\w?\\d+(\\-\\d+)?\\w?\\s+)(?P<rd_nm>[a-zA-z \\-]+)\\s+(?P<rd_tp>Terrace|Way|Walk|St|Rd|Ave|Cl|Ct|Cres|Blvd|Dr|Ln|Pl|Sq|Pde)', 'gm')
const str = `Burrah lodge, 15 Anne Jameson Pl
123 Main St
Unit 84 56 Newcombe Terrace`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}