import re
regex = re.compile(r"^(1?)(?:((\s?\(\d{3}\)\s?|\s?\d{3}\s?)\-?\d{3}\s?\-?\d{4}$))", flags=re.MULTILINE)
test_str = ("555-555-5555\n"
"(555)555-5555\n"
"(555) 555-5555\n"
"555 555 5555\n"
"5555555555\n"
"1 555 555 5555\n"
"1 (555) 555-5555\n\n"
"2 (757) 622-7382\n"
"(6054756961)\n"
"55555555\n"
"123**&!!asdf#\n"
"555-5555\n\n"
"1 555)555-5555\n"
"(6054756961)\n"
"(555-555-5555\n"
"555)-555-5555\n"
"(275)76227382")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")