import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n?(.*?DAN.*?)\\n\\n?(.*?)\\n(.*)";
final String string = "DAN 1\n\n"
+ "LJUBLJANA – GORNO ALTAJSK\n"
+ "Odhod in vožnja proti letališču. Polet proti Moskvi.\n\n"
+ "DAN 2\n\n"
+ "GORNO ALTAJSK – KANSKA DOLINA – GORNJI UJMON – TJUNGUR – KUČERLA\n"
+ "Zjutraj pristanek na letališču. Transfer preko Seminskega prevala v Kansko dolino. Ogled Taldinskih kurganov, jame Beli kamen, muzej Rericha v Gornjem Ujmonu, postanek v Ust Koksi. Zvečer prihod v Tjungur (v prevodu šamanski boben) in preko reke Katun v Kučerlo.\n\n"
+ "DAN 3\n\n"
+ "TREKING S KONJI\n"
+ "Čez prelaz Kuzujak (1513m) v dolino reke Akkem, kjer taborimo (35 km)\n\n"
+ "DAN 4\n\n"
+ "TREKING S KONJI\n"
+ "Po dolini ob potoku nadaljujemo sprva zmerno, nato pa vedno bolj strmo navzgor. Za nami ostaja prvobitni sibirski gozd, pred nami se razprostirajo gorski travniki z bujno vegetacijo. Na pobočju gore Tukman s čudovitimi pogledom na Beluho postavimo na višini 2000m naš drugi tabor. 6-7 h, 14 km, 900 v.m.\n\n"
+ "DAN 5\n\n"
+ "TREKING S KONJI\n"
+ "Pot nas vodi ob reki Aktaš po visoki planoti do slikovitega jezera, vseskozi nas spremlja panorama na zasnežene vrhove. Tabor postavimo v cedrinem gozdu na višini 2000m. 7-8 h, 20 km, 100 v.m.\n\n"
+ "DAN 6\n\n"
+ "TREKING S KONJI\n"
+ "Zmeren vzpon na vrh Černaja (3019m) in spust k reki Tekelju na višini 1800m, kjer bo naš četrti tabor. To področje se omenja tudi kot življenski prostor snežnega leoparda! Kratek izlet do dveh divjih slapov nižje ob reki in povratek v tabor. 5-6 h, 18 km, 700 v.m.\n\n"
+ "DAN 7\n\n"
+ "TREKING S KONJI\n"
+ "Pot nas vodi po odprtih razglednih planotah in grebenih do doline Jarlu in do Akkemskega jezera na višini 1950m. Tu bo naš tabor naslednja dva dni. 7-8 h, 15 km, 600 v.m.\n\n"
+ "DAN 8\n\n"
+ "AKKEMSKO JEZERO\n"
+ "Počitek ob jezeru, po želji izlet na ledenik pod Beluho, do jezera Gornjih duhov, do Sedmerih jezer ali do »kamnitega mesta« v dolini Yarlu.\n\n"
+ "DAN 9\n"
+ "AKKEMSKO JEZERO\n"
+ "Začetek drugega dela našega trekinga v Sibiriji. Vzpon na prelaz Karatjurek, ki je s 3060m najvišja točka našega trekinga. Nepozaben pogled na Beluho, ledenik in jezero Akkem. Spust v dolino reke Kučerle in postavitev tabora v cedrinem gozdu. 6-8 h, 15 km, 1000 m\n"
+ "DAN 10\n"
+ "TREKING S KONJI \n"
+ "Po kratkem vzponu na gozdni plato nadaljujemo s spustom do Kučerlinskega jezera na višini 1760m. Za razliko od ledeniškega Akkemskega jezera, je to jezero bolj globoko in polno rib. Tu postavimo naš naslednji tabor. 4-6 h, 13 km, 300 v.m.\n\n"
+ "DAN 11\n"
+ "KUČERLINSKO JEZERO\n"
+ "Po dolini reke Kučerle se v zmernem spustu po značilni sibirski tajgi vračamo proti domu. Na bregu reke postavimo naš zadnji tabor na trekingu. 7-8 h, 21 km, 460 v. m.\n\n"
+ "DAN 12\n"
+ "TREKING S KONJI \n"
+ "Nadaljujemo s spustom ob reki, ob poti si ogledamo starodavne petroglife na skali. Zvečer nas v vasi Kučerla čaka tradicionalna altajska pogostitev in savna. 4-6 h, 24 km, 450 v.m\n\n"
+ "DAN 13\n"
+ "KUČERLA – GORNO ALTAJSK/BARNAUL\n"
+ "Povratek v Gorno Altajsk, na poti ogled muzeja Rericha in galerije kamnov, namestitev v hotelu v Gorno Altajsku, počitek.\n\n"
+ "DAN 14\n"
+ "GORNO ALTAJSK/BARNAUL – LJUBLJANA\n"
+ "Jutranji polet proti Moskvi, prihod v Ljubljano predvidoma ob 17.00.";
final String subst = "<p class=\"dan\">$1</p>\\n<p class=\"pot\">$2</p>\\n<p class=\"opis\">$3</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}