using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<filename>\w+\.csv)";
string input = @"billy_bob.csv
random_longer_filename.csv
yankee.doc
goo.csv";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}