$re = '/(?<filename>\w+\.csv)/';
$str = 'billy_bob.csv
random_longer_filename.csv
yankee.doc
goo.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);