package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Base\s+Attack\/Grapple:\s*[\+–\d\/]+`)
var str = `flat-footed 14 Base Attack/Grapple: +1/–3Attack: Morningstar +2 melee (1d6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}