$re = '/Base\s+Attack\/Grapple:\s*[\+–\d\/]+/m';
$str = 'flat-footed 14 Base Attack/Grapple: +1/–3Attack: Morningstar +2 melee (1d6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);