import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bSOURCE#.*\\s*^\\[1](.*\\s*^(?!\\[\\d+]).*\\bPNR(?:\\n(?!\\[\\d+]).*)*(?:\\n\\[\\d+].*)*)";
final String string = "**** SOURCE#24 ****\n\n"
+ "[1] Source Location [Local/Remote] : Remote\n\n"
+ " Remote Host Name : PNQ\n"
+ " User Name : foo\n\n"
+ "[2] Source directory : HDPGWRF\n"
+ "[3] Directory poll interval : 30\n"
+ "[4] File name format : ACR_FILEFORMAT\n"
+ "[5] Delete files from source : y\n\n"
+ "**** SOURCE#25 ****\n\n"
+ "[1] Source Location [Local/Remote] : Remote\n\n"
+ " Remote Host Name : PNR\n"
+ " User Name : foo\n\n"
+ "[2] Source directory : HDPGWRF\n"
+ "[3] Directory poll interval : 30\n"
+ "[4] File name format : ACR_FILEFORMAT\n"
+ "[5] Delete files from source : y\n\n"
+ "**** SOURCE#26 ****\n"
+ "etc.....";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}