const regex = new RegExp('\\bSOURCE#.*\\s*^\\[1](.*\\s*^(?!\\[\\d+]).*\\bPNR(?:\\n(?!\\[\\d+]).*)*(?:\\n\\[\\d+].*)*)', 'gm')
const str = `**** SOURCE#24 ****
[1] Source Location [Local/Remote] : Remote
Remote Host Name : PNQ
User Name : foo
[2] Source directory : HDPGWRF
[3] Directory poll interval : 30
[4] File name format : ACR_FILEFORMAT
[5] Delete files from source : y
**** SOURCE#25 ****
[1] Source Location [Local/Remote] : Remote
Remote Host Name : PNR
User Name : foo
[2] Source directory : HDPGWRF
[3] Directory poll interval : 30
[4] File name format : ACR_FILEFORMAT
[5] Delete files from source : y
**** SOURCE#26 ****
etc.....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}