re = /(?<!&#([0-46-9]\d|5[0-8]))(?<!&#\d{3})(?<!&[a-z])(?<!&[a-z]{2})(?<!&[a-z]{3})(?<!&[a-z]{4})(?<!&[a-z]{5})(?<!&[a-z]{6})(?<!&[a-z]{7})(?<!&[a-z]{8});\)/m
str = 'Should work
;)
;)
hey;)
nbsp;)
Should NOT work
)
ɘ)
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end