import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(?<Event_Log>[^\\\"]+)\\\"";
final String string = "2021-12-04T01:29:48.015524+00:00 USHCO-EXXON, ipsec-ike-down, 689, \"IKE connection with peer 10.218.42.113 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
+ "2021-12-04T01:29:15.007722+00:00 USHCO-EXXON, ipsec-tunnel-down, 687, \"IPSEC tunnel with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
+ "2021-12-04T01:29:15.007722+00:00 USHCO-EXXON, ipsec-ike-down, 686, \"IKE connection with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
+ "2021-12-04T01:29:14.807814+00:00 USHCO-EXXON, ipsec-tunnel-down, 872, \"IPSEC tunnel with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB\n\n"
+ "2021-12-04T01:29:14.807814+00:00 USHCO-EXXON, ipsec-ike-down, 871, \"IKE connection with peer 10.218.42.111 (routing-instance EXXON-Control-VR) is up\", USPAB";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}