$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~!@#$%^&*+]).{8,}$/m';
$str = 'aB1!qwertyu
aB1!
qwertyuiop
QWERTY123
1234567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);