re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~!@#$%^&*+]).{8,}$/m
str = 'aB1!qwertyu
aB1!
qwertyuiop
QWERTY123
1234567890
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end