re = /(?<=\()\d+\.?\d?(?=g\))/m
str = 'blah blah blah 6521 (3.2g) 345 (8g) 34 etc...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end