$re = '/(?=[A-Z][+−-]?\d+\b)/m';
$str = 'N678 à p. du 11.6.23 C+23.6.23 N−14.,24.7.23
N678 N−12.,13.12.22,18.,19.,31.1.,9.2.,7. au 10.,13. au 17.,20.,21.,22.,28.
au 31.3.,6.,13.,19.,20.4.,5.,8.5.23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);