import re
regex = re.compile(r"(?=[A-Z][+−-]?\d+\b)", flags=re.MULTILINE)
test_str = ("N678 à p. du 11.6.23 C+23.6.23 N−14.,24.7.23\n\n"
"N678 N−12.,13.12.22,18.,19.,31.1.,9.2.,7. au 10.,13. au 17.,20.,21.,22.,28.\n"
"au 31.3.,6.,13.,19.,20.4.,5.,8.5.23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")