using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"AddAgenda\(""([^""]+)"",\s*\{\s*([^}]+)\},\s*\{\s*([^}]+)\s*\}\)";
string input = @"AddAgenda(""Gangster's agenda"",
{
TEAM_HITMAN,
TEAM_POLICE
},
{
TEAM_GANG,
TEAM_MAFIA,
TEAM_GANGSTER
})";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}