import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "AddAgenda\\(\"([^\"]+)\",\\s*\\{\\s*([^\\}]+)\\},\\s*\\{\\s*([^\\}]+)\\s*\\}\\)";
final String string = "AddAgenda(\"Gangster's agenda\", \n"
+ "{ \n"
+ " TEAM_HITMAN, \n"
+ " TEAM_POLICE\n"
+ "}, \n"
+ "{ \n"
+ " TEAM_GANG,\n"
+ " TEAM_MAFIA,\n"
+ " TEAM_GANGSTER\n"
+ "})";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}