package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]{2}\d{3}$`)
var str = `ds123
ab333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}