$re = '/(?:https://(\d+)/v[a-z]*(\d+)/|\G(?!^))([a-z]+)/?/m';
$str = 'https://123/v1/a/b/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);