re = /(?:https:\/\/(\d+)\/v[a-z]*(\d+)\/|\G(?!^))([a-z]+)\/?/m
str = 'https://123/v1/a/b/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end