#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:)?(?:\/\/)?(?:(?:www\.|m\.)?youtube(?:-nocookie)?\.com\/(?:v\/|e\/|embed\/|w\/|(?:watch\?v=|(?:(?:\?|watch\?)(?:[\w]+=[\w]+&?)+)v=)?|shorts\/)|youtu\.be\/(?:watch\?v=)?)([\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['\"][^<>]*>|<\/a>))[?=&+%\w.-]*$"
Local $sString = "thisdoesnotmatch" & @CRLF & _
"seulement11" & @CRLF & _
"l_la5XiQJdk" & @CRLF & _
"Qa5McwO3qY0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/w/0tI4nOURzKI" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/shorts/Qa5McwO3qY0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"youtube.com/watch?v=vpiMAaPTze8" & @CRLF & _
"//youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/watch?v=vpiMAaPTze8" & @CRLF & _
"http://youtu.be/l_la5XiQJdk" & @CRLF & _
"http://youtu.be/NLqAF9hrVbY" & @CRLF & _
"https://youtu.be/qT47KF5pvfw" & @CRLF & _
"https://youtu.be/zImHyTyYhM8?t=4s" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk?t=120" & @CRLF & _
"https://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"http://youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"//youtu.be/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube-nocookie.com/watch?v=NLqAF9hrVbY" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US" & @CRLF & _
"http://www.youtube.com/v/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/embed/NLqAF9hrVbY" & @CRLF & _
"https://www.youtube.com/embed/NLqAF9hrVbY" & @CRLF & _
"http://www.youtube.com/embed/dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1" & @CRLF & _
"https://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/embed/DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/e/dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?v=NLqAF9hrVbY" & @CRLF & _
"http://www.youtube.com/watch?v=spDj54kf-vY&feature=g-vrec" & @CRLF & _
"http://www.youtube.com/watch?v=spDj54kf-vY&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/watch?v=MRl7cxSOXdU&feature=youtu.be" & @CRLF & _
"https://www.youtube.com/watch?v=q07SQFmL4rM" & @CRLF & _
"https://www.youtube.com/watch?v=q07SQFmL4yM" & @CRLF & _
"https://www.youtube.com/watch?v=zImHyTyYhM8&t=4s" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured" & @CRLF & _
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"www.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8" & @CRLF & _
"https://www.youtube.com/watch?v=zImHyTyYhM8" & @CRLF & _
"This working:" & @CRLF & _
"https://www.youtube.com/watch?v=zImHyTyYhM8&time_continue=4&" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=player_embedded" & @CRLF & _
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/?aa=aa&bbb=bbb&cccc=cccc&v=dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/?aa=aa&bbb=bbb&v=dQw4w9WgXcQ&cccc=cccc" & @CRLF & _
"http://www.youtube.com/?aa=aa&v=dQw4w9WgXcQ&bbb=bbb&cccc=cccc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"//m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"m.youtube.com/watch?v=DFYRQ_zQ-gk" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"------------------------------- All wrong urls -------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ" & @CRLF & _
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo" & @CRLF & _
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/2/PPS-8DMrAn4" & @CRLF & _
"http://gdata.youtube.com/feeds/api/videos/NLqAF9hrVbY" & @CRLF & _
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk" & @CRLF & _
"http://www.youtube.com/?v=dQw4w9WgXcQ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://www.youtube.com/&v=dQw4w9WgXcQ" & @CRLF & _
"www.youtube.com/watch/ccc/ddd/DFYRQ_zQ-gk&feature=featured" & @CRLF & _
"//www.youtube.com/vk/DFYRQ_zQwww" & @CRLF & _
"//www.youtube.com/sdasdsadsd/DFYRQ_zQwww/fdfsdf/sdfsdfsdf" & @CRLF & _
"www.youtube.com/awssssssss" & @CRLF & _
"youtu.be/e/e/e/e/e/DFYRQ_zQwww/d/d/d/d/a/sfd/asd/as/DFYRQ_zQwww" & @CRLF & _
"https://www.youtube.com/v=0tI4nOURzKI" & @CRLF & _
"www.youtube.com/v=/DFYRQ_zQwww" & @CRLF & _
"www.youtube.com/vDFYRQ_zQwww" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")