# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:)?(?:\/\/)?(?:(?:www\.|m\.)?youtube(?:-nocookie)?\.com\/(?:v\/|e\/|embed\/|w\/|(?:watch\?v=|(?:(?:\?|watch\?)(?:[\w]+=[\w]+&?)+)v=)?|shorts\/)|youtu\.be\/(?:watch\?v=)?)([\w-]{11})(?=[^\w-]|$)(?![?=&+%\w.-]*(?:['\"][^<>]*>|<\/a>))[?=&+%\w.-]*$"
test_str = ("thisdoesnotmatch\n"
"seulement11\n"
"l_la5XiQJdk\n"
"Qa5McwO3qY0\n\n\n\n"
"https://www.youtube.com/w/0tI4nOURzKI\n\n\n"
"https://www.youtube.com/shorts/Qa5McwO3qY0\n\n\n"
"youtube.com/watch?v=vpiMAaPTze8\n"
"//youtu.be/DFYRQ_zQ-gk\n"
"youtu.be/DFYRQ_zQ-gk\n"
"http://www.youtube.com/watch?v=vpiMAaPTze8\n"
"http://youtu.be/l_la5XiQJdk\n"
"http://youtu.be/NLqAF9hrVbY\n"
"https://youtu.be/qT47KF5pvfw\n"
"https://youtu.be/zImHyTyYhM8?t=4s\n"
"https://youtu.be/DFYRQ_zQ-gk?t=120\n"
"https://youtu.be/DFYRQ_zQ-gk\n"
"http://youtu.be/DFYRQ_zQ-gk\n"
"//youtu.be/DFYRQ_zQ-gk\n\n\n\n"
"http://www.youtube-nocookie.com/watch?v=NLqAF9hrVbY\n\n\n\n"
"https://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"http://www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"//www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"www.youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"youtube.com/v/DFYRQ_zQ-gk?fs=1&hl=en_US\n"
"http://www.youtube.com/v/dQw4w9WgXcQ\n"
"http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US\n\n"
"http://www.youtube.com/embed/NLqAF9hrVbY\n"
"https://www.youtube.com/embed/NLqAF9hrVbY\n"
"http://www.youtube.com/embed/dQw4w9WgXcQ\n"
"https://www.youtube.com/embed/DFYRQ_zQ-gk?autoplay=1\n"
"https://www.youtube.com/embed/DFYRQ_zQ-gk\n"
"http://www.youtube.com/embed/DFYRQ_zQ-gk\n"
"//www.youtube.com/embed/DFYRQ_zQ-gk\n"
"www.youtube.com/embed/DFYRQ_zQ-gk\n"
"https://youtube.com/embed/DFYRQ_zQ-gk\n"
"http://youtube.com/embed/DFYRQ_zQ-gk\n"
"//youtube.com/embed/DFYRQ_zQ-gk\n"
"youtube.com/embed/DFYRQ_zQ-gk\n\n"
"http://www.youtube.com/e/dQw4w9WgXcQ\n\n"
"http://www.youtube.com/watch?v=NLqAF9hrVbY\n"
"http://www.youtube.com/watch?v=spDj54kf-vY&feature=g-vrec\n"
"http://www.youtube.com/watch?v=spDj54kf-vY&feature=youtu.be\n"
"https://www.youtube.com/watch?v=MRl7cxSOXdU&feature=youtu.be\n"
"https://www.youtube.com/watch?v=q07SQFmL4rM\n"
"https://www.youtube.com/watch?v=q07SQFmL4yM\n"
"https://www.youtube.com/watch?v=zImHyTyYhM8&t=4s\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk&feature=featured\n"
"https://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"www.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//youtube.com/watch?v=DFYRQ_zQ-gk\n"
"youtube.com/watch?v=DFYRQ_zQ-gk\n"
"https://www.youtube.com/watch?time_continue=4&v=zImHyTyYhM8\n"
"https://www.youtube.com/watch?v=zImHyTyYhM8\n"
"This working:\n"
"https://www.youtube.com/watch?v=zImHyTyYhM8&time_continue=4&\n\n"
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=player_embedded\n"
"http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
"http://www.youtube.com/?aa=aa&bbb=bbb&cccc=cccc&v=dQw4w9WgXcQ\n"
"http://www.youtube.com/?aa=aa&bbb=bbb&v=dQw4w9WgXcQ&cccc=cccc\n"
"http://www.youtube.com/?aa=aa&v=dQw4w9WgXcQ&bbb=bbb&cccc=cccc\n\n\n\n"
"https://m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"http://m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"//m.youtube.com/watch?v=DFYRQ_zQ-gk\n"
"m.youtube.com/watch?v=DFYRQ_zQ-gk\n\n\n\n"
"------------------------------- All wrong urls -------------------------------------------------\n\n"
"http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ\n"
"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ\n"
"http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo\n"
"http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
"http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/2/PPS-8DMrAn4\n"
"http://gdata.youtube.com/feeds/api/videos/NLqAF9hrVbY\n"
"https://www.youtube.com/HamdiKickProduction?v=DFYRQ_zQ-gk\n"
"http://www.youtube.com/?v=dQw4w9WgXcQ\n\n\n\n"
"http://www.youtube.com/&v=dQw4w9WgXcQ\n"
"www.youtube.com/watch/ccc/ddd/DFYRQ_zQ-gk&feature=featured\n"
"//www.youtube.com/vk/DFYRQ_zQwww\n"
"//www.youtube.com/sdasdsadsd/DFYRQ_zQwww/fdfsdf/sdfsdfsdf\n"
"www.youtube.com/awssssssss\n"
"youtu.be/e/e/e/e/e/DFYRQ_zQwww/d/d/d/d/a/sfd/asd/as/DFYRQ_zQwww\n"
"https://www.youtube.com/v=0tI4nOURzKI\n"
"www.youtube.com/v=/DFYRQ_zQwww\n"
"www.youtube.com/vDFYRQ_zQwww\n\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.