package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z0-9]+(?:_\{[^\}]+\})?`)
var str = `x_{t+1}+y_{t}=z_{t-1}+pi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}