$re = '/[a-z0-9]+(?:_\{[^\}]+\})?/m';
$str = 'x_{t+1}+y_{t}=z_{t-1}+pi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);