import re
regex = re.compile(r"(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})", flags=re.MULTILINE)
test_str = ("-11,252.40\n"
"-306.00\n"
"11,252.40\n"
"-10,946.40\n"
"306.00\n"
"-54,974.32\n"
"-55,356.82\n"
"-2,695.67\n"
"50.00\n"
"1.00\n"
"540,000.00\n"
"1,540,000.00\n"
"-11,540,000.00\n"
"-111,540,000.45\n\n"
"05/02\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")