import Foundation
let pattern = #"(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-11,252.40
-306.00
11,252.40
-10,946.40
306.00
-54,974.32
-55,356.82
-2,695.67
50.00
1.00
540,000.00
1,540,000.00
-11,540,000.00
-111,540,000.45
05/02
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)