re = /^(?=.{4}$)(?![^no\n]*[no])(?=[^e\n]*e)[^i\n]*i.*$/m
str = 'one
two
three
four
five
six
seven
eight
nine
ten
eleven
twelve
tree'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end