$re = '/\b(co|co.|co-operative|limited)(?=\s|$)/im';
$str = 'basic school co-operative limited';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);