re = /\b(co|co.|co-operative|limited)(?=\s|$)/im
str = 'basic school co-operative limited'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end