re = /.*?(?<match>\(Foreign ID[0-9]{1,5}\)).*/m
str = '[GLPI #000001] Ticket subject with (Foreign ID00001) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end