package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^(<\/?\w+>)]\d+`)
var str = ` <TBODY><TR><TD>1850</TD><TD>-0.373</TD><TD>-0.339</TD><TD>-0.425</TD></TR></TBODY>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}