re = /[^(<\/?\w+>)]\d+/m
str = ' <TBODY><TR><TD>1850</TD><TD>-0.373</TD><TD>-0.339</TD><TD>-0.425</TD></TR></TBODY>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end