#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\.([0-9]{3}))?(Z)?)?"
Local $sString = "2022-01-15" & @CRLF & _
"2022-01-15 12:07" & @CRLF & _
"2022-01-15T12:07" & @CRLF & _
"2022-01-15 12:07Z" & @CRLF & _
"2022-01-15T12:07Z" & @CRLF & _
"2022-01-15 12:07:30" & @CRLF & _
"2022-01-15T12:07:30" & @CRLF & _
"2022-01-15 12:07:30Z" & @CRLF & _
"2022-01-15T12:07:30Z" & @CRLF & _
"2022-01-15 12:07:30.286" & @CRLF & _
"2022-01-15T12:07:30.286" & @CRLF & _
"2022-01-15 12:07:30.286Z" & @CRLF & _
"2022-01-15T12:07:30.286Z" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")