import Foundation
let pattern = #"(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\.([0-9]{3}))?(Z)?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2022-01-15
2022-01-15 12:07
2022-01-15T12:07
2022-01-15 12:07Z
2022-01-15T12:07Z
2022-01-15 12:07:30
2022-01-15T12:07:30
2022-01-15 12:07:30Z
2022-01-15T12:07:30Z
2022-01-15 12:07:30.286
2022-01-15T12:07:30.286
2022-01-15 12:07:30.286Z
2022-01-15T12:07:30.286Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)