$re = '/(fa.*?at)/';
$str = 'The fat cat sat on the mat and another fat cat got jealous.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);