re = /(fa.*?at)/
str = 'The fat cat sat on the mat and another fat cat got jealous.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end