import re
regex = re.compile(r"(?:\([A-Z]+\))?FS[A-Z ]*-\d(?:[^\n,()-]*\w)?", flags=re.MULTILINE)
test_str = ("Fakturasadas : (S)FSK-69/23/GFK/12hjkhjkddddd\n\n"
"(S)FSK-69/23/GFK/12S Z (S)FSK-69/23/GFK/ 1 2 .)\n\n\n"
"FS-1195,1196,1197,2072,2073/24/GF/02, (S)FS-1195/24/GF/02, (S)FS-1196/24/GF/02, (S)FS-1197/24/GF/02, (S)FS-2072/24/GF/02, (S)FS-2073/24/GF/02 (S)FSK-69/23/GF/12\n\n"
"(S)FS-1499/24/GF/01 (S)FS-1500/24/GF/01\n\n"
"I mean if invoice number : FS -444 4/23/F/11 - it also correct to: FS-4444/23/F/11, or FS-4444g/23g/F/1g1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")