package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^Time_in_seconds\[\d+\]Time_in_seconds$\R?)+`)
var str = `Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}