const regex = /(?:^Time_in_seconds\[\d+\]Time_in_seconds$\R?)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^Time_in_seconds\\[\\d+\\]Time_in_seconds$\\R?)+', 'gm')
const str = `Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}